Обчислення кількості унікальних значень

Інколи в роботі нам потрібно порахувати унікальні значення в певній колонці, проте Excel має функції, які підсумовують лише кількість записів в заданому полі, наприклад функція COUNT(). Проблема в тому, що один й той самий код товару чи клієнта може повторюватися кілька разів. Але є вихід, для вирішення нашої задачі ми можемо поєднати стандартні функції Excel. Давайте подивимось як це зробити.

Отже, давайте поєднаємо функції SUM() - сумує, IF() - перевірка умови, FREQUENCY() - підраховує к-ть значень, які попадають в певний інтервал, LEN() - рахує к-ть символів, MATCH() - шукає позицію елемента в масиві:

1. Обчислення кількості унікальних числових значень

=SUM(IF(FREQUENCY(A2:A10;A2:A10)>0;1))

=СУММ(ЕСЛИ(ЧАСТОТА(A2:A10;A2:A10)>0;1))

2. Обчислення кількості унікальних числових та текстових значень (не працює, якщо є порожні комірки)

=SUM(IF(FREQUENCY(MATCH(B2:B10;B2:B10;0);MATCH(B2:B10;B2:B10;0))>0;1))

=СУММ(ЕСЛИ(ЧАСТОТА(ПОИСКПОЗ(B2:B10;B2:B10;0);ПОИСКПОЗ(B2:B10;B2:B10;0))>0;1))

3. Обчислення кількості унікальних значень (універсальна формула)

=SUM(IF(FREQUENCY(IF(LEN(A2:A10)>0;MATCH(A2:A10;A2:A10;0);"");IF(LEN(A2:A10)>0;MATCH(A2:A10;A2:A10;0);""))>0;1))

=СУММ(ЕСЛИ(ЧАСТОТА(ЕСЛИ(ДЛСТР(A2:A10)>0;ПОИСКПОЗ(A2:A10;A2:A10;0);"");ЕСЛИ(ДЛСТР(A2:A10)>0;ПОИСКПОЗ(A2:A10;A2:A10;0);""))>0;1))

Останню формулу потрібно вводити як формулу масиву, тобто натиснути не просто Enter, а Ctrl+Shift+Enter. Після цього, в рядку формул ми побачимо, що формула взята у фігурні дужки ({ }), це признак того, що введена формула масиву.